What’s Vulnerable › Vulnerabilities
CVE-2023-22518: Atlassian Confluence Data Center and Server Improper Authorization Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-11-07
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-31 · updated 2026-06-17
- Weakness: CWE-863
Description
All versions of Confluence Data Center and Server are affected by this unexploited vulnerability. This Improper Authorization vulnerability allows an unauthenticated attacker to reset Confluence and create a Confluence instance administrator account. Using this account, an attacker can then perform all administrative actions that are available to Confluence instance administrator leading to - but not limited to - full loss of confidentiality, integrity and availability. Atlassian Cloud sites are not affected by this vulnerability. If your Confluence site is accessed via an atlassian.net domain, it is hosted by Atlassian and is not vulnerable to this issue.
Affected products
- Atlassian Confluence Data Center: from 1.0 before 7.19.16; from 7.20.0 before 8.3.4; from 8.4.0 before 8.4.4; from 8.5.0 before 8.5.3; 8.6.0 — fixed in 7.19.16, 8.3.4, 8.4.4, 8.5.3
- Atlassian Confluence Data Center: from 1.0 before 7.19.16; from 7.20.0 before 8.3.4; from 8.4.0 before 8.4.4; from 8.5.0 before 8.5.3; 8.6.0 — fixed in 7.19.16, 8.3.4, 8.4.4, 8.5.3
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.19.16, 8.3.4, 8.4.4, 8.5.3; Atlassian Confluence Data Center 7.19.16, 8.3.4, 8.4.4, 8.5.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/176264/Atlassian-Confluence-Improper-Authorization-Code-Execution.html
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1311473907
- https://jira.atlassian.com/browse/CONFSERVER-93142
- http://packetstormsecurity.com/files/176264/Atlassian-Confluence-Improper-Authorization-Code-Execution.html
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1311473907
- https://jira.atlassian.com/browse/CONFSERVER-93142
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-22518
Get alerted when CVE-2023-22518 or the next vulnerability affects your stack