What’s Vulnerable › Vulnerabilities
CVE-2023-2252: Directorist < 7.5.4 - Admin+ LFI
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-22
Description
The Directorist WordPress plugin before 7.5.4 is vulnerable to Local File Inclusion as it does not validate the file parameter when importing CSV files.
Affected products
- wpwax Directorist: AI-Powered Business Directory, Listings & Classified Ads: before 7.5.4 — fixed in 7.5.4
How to fix
Upgrade to a fixed version: wpwax Directorist: AI-Powered Business Directory, Listings & Classified Ads 7.5.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9da6eede-10d0-4609-8b97-4a5d38fa8e69/
- https://wpscan.com/vulnerability/9da6eede-10d0-4609-8b97-4a5d38fa8e69/
Get alerted when CVE-2023-2252 or the next vulnerability affects your stack