What’s Vulnerable › Vulnerabilities
CVE-2023-22522
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-06 · updated 2026-06-17
- Weakness: CWE-74
Description
This Template Injection vulnerability allows an authenticated attacker, including one with anonymous access, to inject unsafe user input into a Confluence page. Using this approach, an attacker is able to achieve Remote Code Execution (RCE) on an affected instance. Publicly accessible Confluence Data Center and Server versions as listed below are at risk and require immediate attention. See the advisory for additional details Atlassian Cloud sites are not affected by this vulnerability. If your Confluence site is accessed via an atlassian.net domain, it is hosted by Atlassian and is not vulnerable to this issue.
Affected products
- Atlassian Confluence Data Center: from 4.0 before 7.19.17; from 8.0.0 before 8.4.5; from 8.5.0 before 8.5.4; from 8.6.0 before 8.6.2; 8.7.0 — fixed in 7.19.17, 8.4.5, 8.5.4, 8.6.2
- Atlassian Confluence Data Center: from 4.0 before 7.19.17; from 8.0.0 before 8.4.5; from 8.5.0 before 8.5.4 — fixed in 7.19.17, 8.4.5, 8.5.4
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.19.17, 8.4.5, 8.5.4, 8.6.2; Atlassian Confluence Data Center 7.19.17, 8.4.5, 8.5.4. Check the vendor advisory for mitigations.
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1319570362
- https://jira.atlassian.com/browse/CONFSERVER-93502
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1319570362
- https://jira.atlassian.com/browse/CONFSERVER-93502
Get alerted when CVE-2023-22522 or the next vulnerability affects your stack