What’s Vulnerable › Vulnerabilities
CVE-2023-22526
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-94
Description
This High severity RCE (Remote Code Execution) vulnerability was introduced in version 7.19.0 of Confluence Data Center. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 7.2, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 7.19: Upgrade to a release 7.19.17, or any higher 7.19.x release Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was discovered by m1sn0w and reported via our Bug Bounty program
Affected products
- Atlassian Confluence Data Center: from 7.19.0 before 7.19.17; from 8.5.0 before 8.5.5; from 8.7.0 before 8.7.2 — fixed in 7.19.17, 8.5.5, 8.7.2
- Atlassian Confluence Data Center: from 7.19 before 7.19.17; from 8.5.0 before 8.5.5; from 8.7.0 through 8.7.2 — fixed in 7.19.17, 8.5.5
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.19.17, 8.5.5, 8.7.2; Atlassian Confluence Data Center 7.19.17, 8.5.5. Check the vendor advisory for mitigations.
References
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1333335615
- https://jira.atlassian.com/browse/CONFSERVER-93516
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1333335615
- https://jira.atlassian.com/browse/CONFSERVER-93516
Get alerted when CVE-2023-22526 or the next vulnerability affects your stack