What’s Vulnerable › Vulnerabilities
CVE-2023-2254: Ko-fi Button < 1.3.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ko-fi Button WordPress plugin before 1.3.3 does not properly some of its settings, which could allow high-privilege users to perform Stored Cross-Site Scripting (XSS) attacks even when the unfiltered_html capability is disallowed (for example in multisite setup), and we consider it a low risk.
Affected products
- Ko-fi Button: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: Ko-fi Button 1.3.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8886ec5f-8465-448f-adbd-68a3e84c5dec
- https://wpscan.com/vulnerability/8886ec5f-8465-448f-adbd-68a3e84c5dec
Get alerted when CVE-2023-2254 or the next vulnerability affects your stack