What’s Vulnerable › Vulnerabilities
CVE-2023-22578: Sequalize - Default support for “raw attributes” when using parentheses
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-790
Description
Due to improper artibute filtering in the sequalize js library, can a attacker peform SQL injections.
Affected products
- sequelize: before 6.29.0; 7.0.0-alpha1, 7.0.0-alpha10, 7.0.0-alpha11, 7.0.0-alpha12, 7.0.0-alpha13, 7.0.0-alpha14 (+19) — fixed in 6.29.0
How to fix
Upgrade to a fixed version: sequelize 6.29.0. Check the vendor advisory for mitigations.
References
- https://csirt.divd.nl/CVE-2023-22578
- https://csirt.divd.nl/DIVD-2022-00020/
- https://csirt.divd.nl/CVE-2023-22578
- https://csirt.divd.nl/DIVD-2022-00020/
Get alerted when CVE-2023-22578 or the next vulnerability affects your stack