What’s Vulnerable › Vulnerabilities
CVE-2023-22595: IBM B2B Advanced Communication cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-31 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM B2B Advanced Communications 1.0.0.0 and IBM Multi-Enterprise Integration Gateway 1.0.0.1 are vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 244076.
Affected products
- IBM B2B Advanced Communications: from 1.0 before 1.0.0.8 — fixed in 1.0.0.8
- IBM Multi-Enterprise Integration Gateway: 1.0.0.1
How to fix
Upgrade to a fixed version: IBM B2B Advanced Communications 1.0.0.8. Check the vendor advisory for mitigations.
References
- https://www.ibm.com/support/pages/node/7014929
- https://www.ibm.com/support/pages/node/7014929
- https://www.ibm.com/support/pages/node/7014929
- https://www.ibm.com/support/pages/node/7014929
- https://www.ibm.com/support/pages/node/7014929
- https://www.ibm.com/support/pages/node/7014929
- https://www.ibm.com/support/pages/node/7014929
- https://www.ibm.com/support/pages/node/7014929
Get alerted when CVE-2023-22595 or the next vulnerability affects your stack