What’s Vulnerable › Vulnerabilities
CVE-2023-22620
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-12 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue was discovered in SecurePoint UTM before 12.2.5.1. The firewall's endpoint at /spcgi.cgi allows sessionid information disclosure via an invalid authentication attempt. This can afterwards be used to bypass the device's authentication and get access to the administrative interface.
Affected products
- Securepoint Unified Threat Management: from 12.2.3.1 before 12.2.5.1 — fixed in 12.2.5.1
How to fix
Upgrade to a fixed version: Securepoint Unified Threat Management 12.2.5.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171924/SecurePoint-UTM-12.x-Session-ID-Leak.html
- http://seclists.org/fulldisclosure/2023/Apr/7
- https://github.com/MrTuxracer/advisories/blob/master/CVEs/CVE-2023-22620.txt
- https://rcesecurity.com
- http://packetstormsecurity.com/files/171924/SecurePoint-UTM-12.x-Session-ID-Leak.html
- http://seclists.org/fulldisclosure/2023/Apr/7
- https://github.com/MrTuxracer/advisories/blob/master/CVEs/CVE-2023-22620.txt
- https://rcesecurity.com
Get alerted when CVE-2023-22620 or the next vulnerability affects your stack