What’s Vulnerable › Vulnerabilities
CVE-2023-22621
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 70.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-74
Description
Strapi through 4.5.5 allows authenticated Server-Side Template Injection (SSTI) that can be exploited to execute arbitrary code on the server. A remote attacker with access to the Strapi admin panel can inject a crafted payload that executes code on the server into an email template that bypasses the validation checks that should prevent code execution.
Affected products
- strapi: from 3.0.0 before 4.5.6 — fixed in 4.5.6
How to fix
Upgrade to a fixed version: strapi 4.5.6. Check the vendor advisory for mitigations.
References
- https://github.com/strapi/strapi/releases
- https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve
- https://www.ghostccamm.com/blog/multi_strapi_vulns/
- https://github.com/strapi/strapi/releases
- https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve
- https://www.ghostccamm.com/blog/multi_strapi_vulns/
Get alerted when CVE-2023-22621 or the next vulnerability affects your stack