What’s Vulnerable › Vulnerabilities
CVE-2023-22637
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-03 · updated 2026-06-17
- Weakness: CWE-79
Description
An improper neutralization of input during web page generation ('Cross-site Scripting') vulnerability [CWE-79] in FortiNAC-F version 7.2.0, FortiNAC version 9.4.2 and below, 9.2 all versions, 9.1 all versions, 8.8 all versions, 8.7 all versions in License Management would permit an authenticated attacker to trigger remote code execution via crafted licenses.
Affected products
- Fortinet FortiNAC: from 8.7.0 before 9.4.3 — fixed in 9.4.3
- Fortinet FortiNAC-F: 7.2.0
How to fix
Upgrade to a fixed version: Fortinet FortiNAC 9.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-22637 or the next vulnerability affects your stack