What’s Vulnerable › Vulnerabilities
CVE-2023-22640
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-03 · updated 2026-10-22
- Weakness: CWE-787
Description
A out-of-bounds write vulnerability in Fortinet FortiOS 7.2.0 through 7.2.3, FortiOS 7.0.0 through 7.0.10, FortiOS 6.4.0 through 6.4.11, FortiOS 6.2.0 through 6.2.13, FortiOS 6.0.0 through 6.0.16, FortiProxy 7.2.0 through 7.2.1, FortiProxy 7.0.0 through 7.0.7, FortiProxy 2.0 all versions, FortiProxy 01.02 all versions, FortiProxy 1.2 all versions, FortiProxy 01.01 all versions, FortiProxy 1.1 all versions, FortiProxy 01.00 all versions allows an authenticated attacker to execute unauthorized code or commands via specifically crafted requests.
Affected products
- Fortinet FortiOS (FortiGate): from 6.0.0 through 6.0.16; from 6.2.0 before 6.2.14; from 6.4.0 before 6.4.12; from 7.0.0 before 7.0.11; from 7.2.0 before 7.2.4 — fixed in 6.2.14, 6.4.12, 7.0.11, 7.2.4
- Fortinet FortiProxy: 1.0.0, 1.1.0, 1.2.0, 2.0.0
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.2.14, 6.4.12, 7.0.11, 7.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-22640 or the next vulnerability affects your stack