What’s Vulnerable › Vulnerabilities
CVE-2023-22642
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-11 · updated 2026-06-17
- Weakness: CWE-295
Description
An improper certificate validation vulnerability [CWE-295] in FortiAnalyzer and FortiManager 7.2.0 through 7.2.1, 7.0.0 through 7.0.5, 6.4.8 through 6.4.10 may allow a remote and unauthenticated attacker to perform a Man-in-the-Middle attack on the communication channel between the device and the remote FortiGuard server hosting outbreakalert ressources.
Affected products
- Fortinet FortiAnalyzer: from 6.4.8 before 6.4.11; from 7.0.0 before 7.0.6; from 7.2.0 before 7.2.2 — fixed in 6.4.11, 7.0.6, 7.2.2
- Fortinet FortiManager: from 6.4.8 before 6.4.11; from 7.0.0 before 7.0.6; from 7.2.0 before 7.2.2 — fixed in 6.4.11, 7.0.6, 7.2.2
How to fix
Upgrade to a fixed version: Fortinet FortiAnalyzer 6.4.11, 7.0.6, 7.2.2; Fortinet FortiManager 6.4.11, 7.0.6, 7.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-22642 or the next vulnerability affects your stack