What’s Vulnerable › Vulnerabilities
CVE-2023-22643: libzypp-plugin-appdata: potential arbitrary code execution via shell injection due to `os.system` calls
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-07 · updated 2026-06-17
- Weakness: CWE-78
Description
An Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in libzypp-plugin-appdata of SUSE Linux Enterprise Server for SAP 15-SP3; openSUSE Leap 15.4 allows attackers that can trick users to use specially crafted REPO_ALIAS, REPO_TYPE or REPO_METADATA_PATH settings to execute code as root. This issue affects: SUSE Linux Enterprise Server for SAP 15-SP3 libzypp-plugin-appdata versions prior to 1.0.1+git.20180426. openSUSE Leap 15.4 libzypp-plugin-appdata versions prior to 1.0.1+git.20180426.
Affected products
- openSUSE Libzypp-Plugin-Appdata: before 1.0.1\+git.20180426 — fixed in 1.0.1\+git.20180426
How to fix
Upgrade to a fixed version: openSUSE Libzypp-Plugin-Appdata 1.0.1\+git.20180426. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-22643 or the next vulnerability affects your stack