What’s Vulnerable › Vulnerabilities
CVE-2023-22645: kubewarden: Excessive permissions for kubewarden-controller-manager-cluster-role
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-269
Description
An Improper Privilege Management vulnerability in SUSE kubewarden allows attackers to read arbitrary secrets if they get access to the ServiceAccount kubewarden-controller This issue affects: SUSE kubewarden kubewarden-controller versions prior to 1.6.0.
Affected products
- SUSE kubewarden: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: SUSE kubewarden 1.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-22645 or the next vulnerability affects your stack