What’s Vulnerable › Vulnerabilities
CVE-2023-22650: Rancher does not automatically clean up a user deleted or disabled from the configured Authentication Provider
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-287
Description
A vulnerability has been identified in which Rancher does not automatically clean up a user which has been deleted from the configured authentication provider (AP). This characteristic also applies to disabled or revoked users, Rancher will not reflect these modifications which may leave the user’s tokens still usable.
Affected products
- SUSE Rancher: from 2.7.0 before 2.7.14; from 2.8.0 before 2.8.5 — fixed in 2.7.14, 2.8.5
How to fix
Upgrade to a fixed version: SUSE Rancher 2.7.14, 2.8.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2023-22650
- https://github.com/rancher/rancher/security/advisories/GHSA-9ghh-mmcq-8phc
Get alerted when CVE-2023-22650 or the next vulnerability affects your stack