What’s Vulnerable › Vulnerabilities
CVE-2023-22727: Database Query::offset() and limit() vulnerable to SQL injection in cakephp
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-17 · updated 2026-06-17
- Weakness: CWE-89
Description
CakePHP is a development framework for PHP web apps. In affected versions the `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2.12, 4.3.11, 4.4.10. Users are advised to upgrade. Users unable to upgrade may mitigate this issue by using CakePHP's Pagination library. Manually validating or casting parameters to these methods will also mitigate the issue.
Affected products
- cakephp: from 4.2.0 before 4.2.12; from 4.3.0 before 4.3.11; from 4.4.0 before 4.4.10 — fixed in 4.2.12, 4.3.11, 4.4.10
How to fix
Upgrade to a fixed version: cakephp 4.2.12, 4.3.11, 4.4.10. Check the vendor advisory for mitigations.
References
- https://bakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html
- https://github.com/cakephp/cakephp/commit/3f463e7084b5a15e67205ced3a622577cca7a239
- https://github.com/cakephp/cakephp/security/advisories/GHSA-6g8q-qfpv-57wp
- https://bakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html
- https://github.com/cakephp/cakephp/commit/3f463e7084b5a15e67205ced3a622577cca7a239
- https://github.com/cakephp/cakephp/security/advisories/GHSA-6g8q-qfpv-57wp
Get alerted when CVE-2023-22727 or the next vulnerability affects your stack