What’s Vulnerable › Vulnerabilities
CVE-2023-22730: Improper Input Validation of Clearance sale in cart
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-17 · updated 2026-06-17
- Weakness: CWE-20
Description
Shopware is an open source commerce platform based on Symfony Framework and Vue js. In affected versions It was possible to put the same line item multiple times in the cart using the AP. The Cart Validators checked the line item's individuality and the user was able to bypass quantity limits in sales. This problem has been fixed with version 6.4.18.1. Users on major versions 6.1, 6.2, and 6.3 may also obtain this fix via a plugin.
Affected products
- shopware: before 6.4.18.1 — fixed in 6.4.18.1
How to fix
Upgrade to a fixed version: shopware 6.4.18.1. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates
- https://github.com/shopware/platform/commit/4fce12096e54b2033832d9104fa2e68888c2b4e9
- https://github.com/shopware/platform/security/advisories/GHSA-8r6h-m72v-38fg
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates
- https://github.com/shopware/platform/commit/4fce12096e54b2033832d9104fa2e68888c2b4e9
- https://github.com/shopware/platform/security/advisories/GHSA-8r6h-m72v-38fg
Get alerted when CVE-2023-22730 or the next vulnerability affects your stack