What’s Vulnerable › Vulnerabilities
CVE-2023-22731: Improper Control of Generation of Code in Twig rendered views in shopware
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-17 · updated 2026-06-17
- Weakness: CWE-94
Description
Shopware is an open source commerce platform based on Symfony Framework and Vue js. In a Twig environment **without the Sandbox extension**, it is possible to refer to PHP functions in twig filters like `map`, `filter`, `sort`. This allows a template to call any global PHP function and thus execute arbitrary code. The attacker must have access to a Twig environment in order to exploit this vulnerability. This problem has been fixed with 6.4.18.1 with an override of the specified filters until the integration of the Sandbox extension has been finished. Users are advised to upgrade. Users of major versions 6.1, 6.2, and 6.3 may also receive this fix via a plugin.
Affected products
- shopware: before 6.4.18.1 — fixed in 6.4.18.1
How to fix
Upgrade to a fixed version: shopware 6.4.18.1. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates
- https://github.com/shopware/platform/commit/89d1ea154689cb6202e0d3a0ceeae0febb0c09e1
- https://github.com/shopware/platform/security/advisories/GHSA-93cw-f5jj-x85w
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates
- https://github.com/shopware/platform/commit/89d1ea154689cb6202e0d3a0ceeae0febb0c09e1
- https://github.com/shopware/platform/security/advisories/GHSA-93cw-f5jj-x85w
Get alerted when CVE-2023-22731 or the next vulnerability affects your stack