What’s Vulnerable › Vulnerabilities
CVE-2023-22734: Improper Input Newsletter subscription option validation in shopware
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-17 · updated 2026-06-17
- Weakness: CWE-20
Description
Shopware is an open source commerce platform based on Symfony Framework and Vue js. The newsletter double opt-in validation was not checked properly, and it was possible to skip the complete double opt in process. As a result operators may have inconsistencies in their newsletter systems. This problem has been fixed with version 6.4.18.1. Users are advised to upgrade. Users unable to upgrade may find security measures are available via a plugin for major versions 6.1, 6.2, and 6.3. Users may also disable newsletter registration completely.
Affected products
- shopware: before 6.4.18.1 — fixed in 6.4.18.1
How to fix
Upgrade to a fixed version: shopware 6.4.18.1. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates
- https://github.com/shopware/platform/commit/f5a95ee2bcf1e546878450963ef1d9886e59a620
- https://github.com/shopware/platform/security/advisories/GHSA-46h7-vj7x-fxg2
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates
- https://github.com/shopware/platform/commit/f5a95ee2bcf1e546878450963ef1d9886e59a620
- https://github.com/shopware/platform/security/advisories/GHSA-46h7-vj7x-fxg2
Get alerted when CVE-2023-22734 or the next vulnerability affects your stack