What’s Vulnerable › Vulnerabilities
CVE-2023-22739: Discourse subject to Allocation of Resources Without Limits or Throttling
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-770
Description
Discourse is an open source platform for community discussion. Versions prior to 3.0.1 (stable), 3.1.0.beta2 (beta), and 3.1.0.beta2 (tests-passed) are subject to Allocation of Resources Without Limits or Throttling. As there is no limit on data contained in a draft, a malicious user can create an arbitrarily large draft, forcing the instance to a crawl. This issue is patched in versions 3.0.1 (stable), 3.1.0.beta2 (beta), and 3.1.0.beta2 (tests-passed). There are no workarounds.
Affected products
- discourse: before 3.0.1; 3.1.0-beta1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: discourse 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-rqgr-g6v7-jcfc
- https://github.com/discourse/discourse/security/advisories/GHSA-rqgr-g6v7-jcfc
Get alerted when CVE-2023-22739 or the next vulnerability affects your stack