What’s Vulnerable › Vulnerabilities
CVE-2023-22740: Discourse vulnerable to Allocation of Resources Without Limits via Chat drafts
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-770
Description
Discourse is an open source platform for community discussion. Versions prior to 3.1.0.beta1 (beta) (tests-passed) are vulnerable to Allocation of Resources Without Limits. Users can create chat drafts of an unlimited length, which can cause a denial of service by generating an excessive load on the server. Additionally, an unlimited number of drafts were loaded when loading the user. This issue has been patched in version 2.1.0.beta1 (beta) and (tests-passed). Users should upgrade to the latest version where a limit has been introduced. There are no workarounds available.
Affected products
- discourse: through 3.0.0
References
- https://github.com/discourse/discourse/commit/5eaf0802398ff06604f03b27a28dd274f2ffa576
- https://github.com/discourse/discourse/security/advisories/GHSA-pwj4-rf62-p224
- https://github.com/discourse/discourse/commit/5eaf0802398ff06604f03b27a28dd274f2ffa576
- https://github.com/discourse/discourse/security/advisories/GHSA-pwj4-rf62-p224
Get alerted when CVE-2023-22740 or the next vulnerability affects your stack