What’s Vulnerable › Vulnerabilities
CVE-2023-22784: Unauthenticated Buffer Overflow Vulnerabilities in Services Accessed by the PAPI Protocol
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-08 · updated 2026-06-17
- Weakness: CWE-120
Description
There are buffer overflow vulnerabilities in multiple underlying services that could lead to unauthenticated remote code execution by sending specially crafted packets destined to the PAPI (Aruba's access point management protocol) UDP port (8211). Successful exploitation of these vulnerabilities result in the ability to execute arbitrary code as a privileged user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise ArubaOS: from 10.3.0.0 through 10.3.1.0
- Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10: from 6.4.0.0 through 6.4.4.8-4.2.4.20; from 6.5.0.0 through 6.5.4.23; from 8.4.0.0 before 8.6.0.0; from 8.6.0.0 through 8.6.0.19; from 8.7.0.0 through 8.9.0.0; from 8.10.0.0 through 8.10.0.4 — fixed in 8.6.0.0
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) HPE Aruba Networking InstantOS and Aruba Access Points running ArubaOS 10 8.6.0.0. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-006.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2023-006.txt
Get alerted when CVE-2023-22784 or the next vulnerability affects your stack