What’s Vulnerable › Vulnerabilities

CVE-2023-2279: WP Directory Kit <= 1.2.1 - Cross-Site Request Forgery to Plugin Settings Change/Delete, Demo Import, Directory Kit Modification/Deletion via admin_page_display

Description

The WP Directory Kit plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.1. This is due to missing or incorrect nonce validation on the 'admin_page_display' function. This makes it possible for unauthenticated attackers to delete or change plugin settings, import demo data, modify or delete Directory Kit related posts and terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Partial patches were made avilable in versions 1.2.0 and 1.2.1 but the issue was not fully patched until 1.2.2

Affected products

How to fix

Upgrade to a fixed version: wpdirectorykit WP Directory Kit 1.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2279 or the next vulnerability affects your stack