What’s Vulnerable › Vulnerabilities
CVE-2023-22809
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 55.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-18 · updated 2026-06-17
- Weakness: CWE-269
Description
In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to append arbitrary entries to the list of files to process. This can lead to privilege escalation. Affected versions are 1.8.0 through 1.9.12.p1. The problem exists because a user-specified editor may contain a "--" argument that defeats a protection mechanism, e.g., an EDITOR='vim -- /path/to/extra/file' value.
Affected products
- Apple macOS: before 13.4 — fixed in 13.4
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 36, 37
- sudo: from 1.8.0 before 1.9.12; 1.9.12, 1.9.12-p1 — fixed in 1.9.12
How to fix
Upgrade to a fixed version: Apple macOS 13.4; sudo 1.9.12. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171644/sudo-1.9.12p1-Privilege-Escalation.html
- http://packetstormsecurity.com/files/172509/Sudoedit-Extra-Arguments-Privilege-Escalation.html
- http://packetstormsecurity.com/files/174234/Cisco-ThousandEyes-Enterprise-Agent-Virtual-Appliance-Arbitrary-File-Modification.html
- http://seclists.org/fulldisclosure/2023/Aug/21
- http://www.openwall.com/lists/oss-security/2023/01/19/1
- https://lists.debian.org/debian-lts-announce/2023/01/msg00012.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2QDGFCGAV5QRJCE6IXRXIS4XJHS57DDH/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G4YNBTTKTRT2ME3NTSXAPTOKYUE47XHZ/
- https://security.gentoo.org/glsa/202305-12
- https://security.netapp.com/advisory/ntap-20230127-0015/
- https://support.apple.com/kb/HT213758
- https://www.debian.org/security/2023/dsa-5321
Get alerted when CVE-2023-22809 or the next vulnerability affects your stack