What’s Vulnerable › Vulnerabilities
CVE-2023-22816: Limited Post-Authentication Remote Command Injection in My Cloud Products
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-30 · updated 2026-06-17
- Weakness: CWE-78
Description
A post-authentication remote command injection vulnerability in a CGI file in Western Digital My Cloud OS 5 devices that could allow an attacker to build files with redirects and execute larger payloads. This issue affects My Cloud OS 5 devices: before 5.26.300.
Affected products
- Western Digital My Cloud: before 5.26.300 — fixed in 5.26.300
How to fix
Upgrade to a fixed version: Western Digital My Cloud 5.26.300. Check the vendor advisory for mitigations.
References
- https://www.westerndigital.com/support/product-security/wdc-23010-my-cloud-firmware-version-5-26-300
- https://www.westerndigital.com/support/product-security/wdc-23010-my-cloud-firmware-version-5-26-300
Get alerted when CVE-2023-22816 or the next vulnerability affects your stack