What’s Vulnerable › Vulnerabilities
CVE-2023-22835: Denial of Service in Foundry Issues
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-10 · updated 2026-06-17
- Weakness: CWE-20
Description
A security defect was identified that enabled a user of Foundry Issues to perform a Denial of Service attack by submitting malformed data in an Issue that caused loss of frontend functionality to all issue participants. This defect was resolved with the release of Foundry Issues 2.510.0 and Foundry Frontend 6.228.0.
Affected products
- Palantir Foundry Frontend: before 6.228.0 — fixed in 6.228.0
- Palantir Foundry Issues: before 2.510.0 — fixed in 2.510.0
How to fix
Upgrade to a fixed version: Palantir Foundry Frontend 6.228.0; Palantir Foundry Issues 2.510.0. Check the vendor advisory for mitigations.
References
- https://palantir.safebase.us/?tcuUid=0e2e79bd-cc03-42a8-92c2-c0e68a1ea53d
- https://palantir.safebase.us/?tcuUid=0e2e79bd-cc03-42a8-92c2-c0e68a1ea53d
Get alerted when CVE-2023-22835 or the next vulnerability affects your stack