What’s Vulnerable › Vulnerabilities
CVE-2023-22847
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-07 · updated 2026-06-17
- Weakness: CWE-200
Description
Information disclosure vulnerability exists in pg_ivm versions prior to 1.5.1. An Incrementally Maintainable Materialized View (IMMV) created by pg_ivm may reflect rows with Row-Level Security that the owner of the IMMV should not have access to. As a result, information in tables protected by Row-Level Security may be retrieved by a user who is not authorized to access it.
Affected products
- IVM Development Group pg_ivm: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: IVM Development Group pg_ivm 1.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/sraoss/pg_ivm
- https://github.com/sraoss/pg_ivm/releases/tag/v1.5.1
- https://jvn.jp/en/jp/JVN19872280/
- https://github.com/sraoss/pg_ivm
- https://github.com/sraoss/pg_ivm/releases/tag/v1.5.1
- https://jvn.jp/en/jp/JVN19872280/
Get alerted when CVE-2023-22847 or the next vulnerability affects your stack