What’s Vulnerable › Vulnerabilities
CVE-2023-2287: Orbit Fox < 2.10.24 - Author+ Server-Side Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-30 · updated 2026-06-17
Description
The Orbit Fox by ThemeIsle WordPress plugin before 2.10.24 does not limit URLs which may be used for the stock photo import feature, allowing the user to specify arbitrary URLs. This leads to a server-side request forgery as the user may force the server to access any URL of their choosing.
Affected products
- themeisle Orbitfox: before 2.10.24 — fixed in 2.10.24
How to fix
Upgrade to a fixed version: themeisle Orbitfox 2.10.24. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1b36a184-2138-4a65-8940-07e7764669bb
- https://wpscan.com/vulnerability/1b36a184-2138-4a65-8940-07e7764669bb
Get alerted when CVE-2023-2287 or the next vulnerability affects your stack