What’s Vulnerable › Vulnerabilities
CVE-2023-22874: IBM MQ denial of service
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-05 · updated 2026-06-17
- Weakness: CWE-400
Description
IBM MQ Clients 9.2 CD, 9.3 CD, and 9.3 LTS are vulnerable to a denial of service attack when processing configuration files. IBM X-Force ID: 244216.
Affected products
- IBM MQ Appliance: from 9.2.0.0 before 9.3.2; from 9.3.0.0 before 9.3.0.5 — fixed in 9.3.0.5, 9.3.2
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.3.0.5, 9.3.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/244216
- https://www.ibm.com/support/pages/node/6985901
- https://exchange.xforce.ibmcloud.com/vulnerabilities/244216
- https://www.ibm.com/support/pages/node/6985901
Get alerted when CVE-2023-22874 or the next vulnerability affects your stack