What’s Vulnerable › Vulnerabilities
CVE-2023-22884: Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-21 · updated 2026-06-17
- Weakness: CWE-77
Description
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow, Apache Software Foundation Apache Airflow MySQL Provider.This issue affects Apache Airflow: before 2.5.1; Apache Airflow MySQL Provider: before 4.0.0.
Affected products
- Apache Airflow: before 2.5.1 — fixed in 2.5.1
- Apache Software Foundation Apache Airflow MySQL Provider: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.5.1; Apache Software Foundation Apache Airflow MySQL Provider 4.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/28811
- https://lists.apache.org/thread/0l0j3nt0t7fzrcjl2ch0jgj6c58kxs5h
- https://github.com/apache/airflow/pull/28811
- https://lists.apache.org/thread/0l0j3nt0t7fzrcjl2ch0jgj6c58kxs5h
Get alerted when CVE-2023-22884 or the next vulnerability affects your stack