What’s Vulnerable › Vulnerabilities
CVE-2023-22886: Apache Airflow JDBC Provider: RCE Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-29 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow JDBC Provider. Airflow JDBC Provider Connection’s [Connection URL] parameters had no restrictions, which made it possible to implement RCE attacks via different type JDBC drivers, obtain airflow server permission. This issue affects Apache Airflow JDBC Provider: before 4.0.0.
Affected products
- Apache Software Foundation Apache Airflow JDBC Provider: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow JDBC Provider 4.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/ynbjwp4n0vzql0xzhog1gkp1ovncf8j3
- https://lists.apache.org/thread/ynbjwp4n0vzql0xzhog1gkp1ovncf8j3
Get alerted when CVE-2023-22886 or the next vulnerability affects your stack