What’s Vulnerable › Vulnerabilities
CVE-2023-22888: Apache Airflow: Scheduler remote DoS
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-20
Description
Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an attacker to cause a service disruption by manipulating the run_id parameter. This vulnerability is considered low since it requires an authenticated user to exploit it. It is recommended to upgrade to a version that is not affected
Affected products
- Apache Airflow: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: Apache Airflow 2.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/32293
- https://lists.apache.org/thread/dnlht2hvm7k81k5tgjtsfmk27c76kq7z
- https://github.com/apache/airflow/pull/32293
- https://lists.apache.org/thread/dnlht2hvm7k81k5tgjtsfmk27c76kq7z
Get alerted when CVE-2023-22888 or the next vulnerability affects your stack