What’s Vulnerable › Vulnerabilities
CVE-2023-22894: Strapi Cleartext Storage of Sensitive Information Vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-10-08
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-19 · updated 2026-10-09
- Weakness: CWE-312
Description
Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter. The attacker can filter users by columns that contain sensitive information and infer a value from API responses. If the attacker has super admin access, then this can be exploited to discover the password hash and password reset token of all users. If the attacker has admin panel access to an account with permission to access the username and email of API users with a lower privileged role (e.g., Editor or Author), then this can be exploited to discover sensitive information for all API users but not other admin accounts.
Affected products
- strapi: from 3.2.1 before 4.8.0 — fixed in 4.8.0
How to fix
Upgrade to a fixed version: strapi 4.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/strapi/strapi/releases
- https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve
- https://www.ghostccamm.com/blog/multi_strapi_vulns/
- https://github.com/strapi/strapi/releases
- https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve
- https://www.ghostccamm.com/blog/multi_strapi_vulns/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-22894
Get alerted when CVE-2023-22894 or the next vulnerability affects your stack