What’s Vulnerable › Vulnerabilities
CVE-2023-22910
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-20 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. There is XSS in Wikibase date formatting via wikibase-time-precision-* fields. This allows JavaScript execution by staff/admin users who do not intentionally have the editsitejs capability.
Affected products
- Wikimedia Foundation MediaWiki: before 1.35.9; from 1.36.0 before 1.38.5; 1.39.0, 1.39.0-rc0, 1.39.0-rc1 — fixed in 1.35.9, 1.38.5
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.9, 1.38.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-22910 or the next vulnerability affects your stack