What’s Vulnerable › Vulnerabilities
CVE-2023-22911
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. E-Widgets does widget replacement in HTML attributes, which can lead to XSS, because widget authors often do not expect that their widget is executed in an HTML attribute context.
Affected products
- Fedoraproject Fedora: 37
- Wikimedia Foundation MediaWiki: before 1.35.9; from 1.36.0 before 1.38.5; 1.39.0, 1.39.0-rc0, 1.39.0-rc1 — fixed in 1.35.9, 1.38.5
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.9, 1.38.5. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AP65YEN762IBNQPOYGUVLTQIDLM5XD2A/
- https://phabricator.wikimedia.org/T149488
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AP65YEN762IBNQPOYGUVLTQIDLM5XD2A/
- https://phabricator.wikimedia.org/T149488
Get alerted when CVE-2023-22911 or the next vulnerability affects your stack