What’s Vulnerable › Vulnerabilities

CVE-2023-22918

Description

A post-authentication information exposure vulnerability in the CGI program of Zyxel ATP series firmware versions 4.32 through 5.35, USG FLEX series firmware versions 4.50 through 5.35, USG FLEX 50(W) firmware versions 4.16 through 5.35, USG20(W)-VPN firmware versions 4.16 through 5.35, VPN series firmware versions 4.30 through 5.35, NWA110AX firmware version 6.50(ABTG.2) and earlier versions, WAC500 firmware version 6.50(ABVS.0) and earlier versions, and WAX510D firmware version 6.50(ABTF.2) and earlier versions, which could allow a remote authenticated attacker to retrieve encrypted information of the administrator on an affected device.

Affected products

How to fix

Upgrade to a fixed version: Zyxel Atp100 Firmware 5.36; Zyxel Atp100W Firmware 5.36; Zyxel Atp200 Firmware 5.36; Zyxel Atp500 Firmware 5.36; Zyxel Atp700 Firmware 5.36; Zyxel Atp800 Firmware 5.36; Zyxel Usg20-Vpn Firmware 5.36; Zyxel USG 20(W)-VPN firmware 5.36; Zyxel firewall (ZLD) 5.36; Zyxel USG FLEX 100(W) firmware 5.36; Zyxel USG FLEX 200 firmware 5.36; Zyxel USG FLEX 500 firmware 5.36. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-22918 or the next vulnerability affects your stack