What’s Vulnerable › Vulnerabilities

CVE-2023-22932: Persistent Cross-Site Scripting through a Base64-encoded Image in a View in Splunk Enterprise

Description

In Splunk Enterprise 9.0 versions before 9.0.4, a View allows for Cross-Site Scripting (XSS) through the error message in a Base64-encoded image. The vulnerability affects instances with Splunk Web enabled. It does not affect Splunk Enterprise versions below 9.0.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.0.4; Splunk Cloud Platform 9.0.2209.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-22932 or the next vulnerability affects your stack