What’s Vulnerable › Vulnerabilities

CVE-2023-22933: Persistent Cross-Site Scripting through the ‘module’ Tag in a View in Splunk Enterprise

Description

In Splunk Enterprise versions below 8.1.13, 8.2.10, and 9.0.4, a View allows for Cross-Site Scripting (XSS) in an extensible mark-up language (XML) View through the ‘layoutPanel’ attribute in the ‘module’ tag’.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 8.1.13, 8.2.10, 9.0.4; Splunk Cloud Platform 9.0.2209. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-22933 or the next vulnerability affects your stack