What’s Vulnerable › Vulnerabilities

CVE-2023-22935: SPL Command Safeguards Bypass via the ‘display.page.search.patterns.sensitivity’ Search Parameter in Splunk Enterprise

Description

In Splunk Enterprise versions below 8.1.13, 8.2.10, and 9.0.4, the ‘display.page.search.patterns.sensitivity’ search parameter lets a search bypass SPL safeguards for risky commands. The vulnerability requires a higher privileged user to initiate a request within their browser and only affects instances with Splunk Web enabled.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 8.1.13, 8.2.10, 9.0.4; Splunk Cloud Platform 9.0.2209.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-22935 or the next vulnerability affects your stack