What’s Vulnerable › Vulnerabilities
CVE-2023-22946: Apache Spark proxy-user privilege escalation from malicious configuration class
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-17 · updated 2026-06-17
- Weakness: CWE-269
Description
In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.
Affected products
- Apache Software Foundation Apache Spark: before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Spark 3.4.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/yllfl25xh5tbotjmg93zrq4bzwhqc0gv
- https://lists.apache.org/thread/yllfl25xh5tbotjmg93zrq4bzwhqc0gv
Get alerted when CVE-2023-22946 or the next vulnerability affects your stack