What’s Vulnerable › Vulnerabilities
CVE-2023-22963
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-11 · updated 2026-06-17
- Weakness: CWE-20
Description
The personnummer implementation before 3.0.3 for Dart mishandles numbers in which the last four digits match the ^000[0-9]$ regular expression.
Affected products
- Personnummer: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: Personnummer 3.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-4xh4-v2pq-jvhm
- https://github.com/personnummer/dart/security/advisories/GHSA-4xh4-v2pq-jvhm
- https://github.com/advisories/GHSA-4xh4-v2pq-jvhm
- https://github.com/personnummer/dart/security/advisories/GHSA-4xh4-v2pq-jvhm
Get alerted when CVE-2023-22963 or the next vulnerability affects your stack