What’s Vulnerable › Vulnerabilities
CVE-2023-22970
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-26 · updated 2026-06-17
Description
Bottles before 51.0 mishandles YAML load, which allows remote code execution via a crafted file.
Affected products
- Fedoraproject Fedora: 37, 38
- Usebottles Bottles: before 51.0 — fixed in 51.0
How to fix
Upgrade to a fixed version: Usebottles Bottles 51.0. Check the vendor advisory for mitigations.
References
- https://github.com/bottlesdevs/Bottles/issues/2463
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N24KI3O3FWGKJSLATY35ZM3CHSABJ6WE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZJZEE4RAAK7OPVQNE4BOWUVQDVSZU6NJ/
- https://github.com/bottlesdevs/Bottles/issues/2463
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N24KI3O3FWGKJSLATY35ZM3CHSABJ6WE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZJZEE4RAAK7OPVQNE4BOWUVQDVSZU6NJ/
Get alerted when CVE-2023-22970 or the next vulnerability affects your stack