What’s Vulnerable › Vulnerabilities
CVE-2023-22972
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-22 · updated 2026-10-23
- Weakness: CWE-79
Description
A Reflected Cross-site scripting (XSS) vulnerability in interface/forms/eye_mag/php/eye_mag_functions.php in OpenEMR < 7.0.0 allows remote authenticated users to inject arbitrary web script or HTML via the REQUEST_URI.
Affected products
- openemr: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: openemr 7.0.0. Check the vendor advisory for mitigations.
References
- https://www.open-emr.org/wiki/index.php/OpenEMR_Patches#7.0.0_Patch_.2811.2F30.2F22.29
- https://www.open-emr.org/wiki/index.php/OpenEMR_Patches#7.0.0_Patch_.2811.2F30.2F22.29
Get alerted when CVE-2023-22972 or the next vulnerability affects your stack