What’s Vulnerable › Vulnerabilities
CVE-2023-22974
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-22 · updated 2026-10-24
- Weakness: CWE-552
Description
A Path Traversal in setup.php in OpenEMR < 7.0.0 allows remote unauthenticated users to read arbitrary files by controlling a connection to an attacker-controlled MySQL server.
Affected products
- openemr: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: openemr 7.0.0. Check the vendor advisory for mitigations.
References
- https://www.open-emr.org/wiki/index.php/OpenEMR_Patches#7.0.0_Patch_.2811.2F30.2F22.29
- https://www.sonarsource.com/blog/openemr-remote-code-execution-in-your-healthcare-system/
- https://www.open-emr.org/wiki/index.php/OpenEMR_Patches#7.0.0_Patch_.2811.2F30.2F22.29
- https://www.sonarsource.com/blog/openemr-remote-code-execution-in-your-healthcare-system/
Get alerted when CVE-2023-22974 or the next vulnerability affects your stack