What’s Vulnerable › Vulnerabilities
CVE-2023-23002
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-01 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel before 5.16.3, drivers/bluetooth/hci_qca.c misinterprets the devm_gpiod_get_index_optional return value (expects it to be NULL in the error case, whereas it is actually an error pointer).
Affected products
- Linux kernel: before 5.16.3 — fixed in 5.16.3
How to fix
Upgrade to a fixed version: Linux kernel 5.16.3. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.16.3
- https://github.com/torvalds/linux/commit/6845667146a28c09b5dfc401c1ad112374087944
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.16.3
- https://github.com/torvalds/linux/commit/6845667146a28c09b5dfc401c1ad112374087944
Get alerted when CVE-2023-23002 or the next vulnerability affects your stack