What’s Vulnerable › Vulnerabilities
CVE-2023-23109
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-27 · updated 2026-06-17
- Weakness: CWE-369
Description
In crasm 1.8-3, invalid input validation, specific files passed to the command line application, can lead to a divide by zero fault in the function opdiv.
Affected products
- Crasm Project Crasm: before 1.11 — fixed in 1.11
How to fix
Upgrade to a fixed version: Crasm Project Crasm 1.11. Check the vendor advisory for mitigations.
References
- https://github.com/WhatTheFuzz/crasm-fuzz/tree/a020ad6ad99a72ca373f7dd1aab3a61a7c87fd66/bug-floating-point-exception
- https://github.com/colinbourassa/crasm/pull/7
- https://github.com/WhatTheFuzz/crasm-fuzz/tree/a020ad6ad99a72ca373f7dd1aab3a61a7c87fd66/bug-floating-point-exception
- https://github.com/colinbourassa/crasm/pull/7
Get alerted when CVE-2023-23109 or the next vulnerability affects your stack