What’s Vulnerable › Vulnerabilities
CVE-2023-2321: WPForms Google Sheet Connector < 3.4.6 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-04 · updated 2026-06-17
Description
The WPForms Google Sheet Connector WordPress plugin before 3.4.6, gsheetconnector-wpforms-pro WordPress plugin through 3.4.6 does not escape a parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- WesternDeal WPForms Google Sheet Connector: before 3.4.6; through 3.4.6 — fixed in 3.4.6
How to fix
Upgrade to a fixed version: WesternDeal WPForms Google Sheet Connector 3.4.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/79a56359-f7e8-4c8c-b0aa-6300f5d57880
- https://wpscan.com/vulnerability/79a56359-f7e8-4c8c-b0aa-6300f5d57880
Get alerted when CVE-2023-2321 or the next vulnerability affects your stack