What’s Vulnerable › Vulnerabilities
CVE-2023-2324: Elementor Forms Google Sheet Connector < 1.0.7 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-04 · updated 2026-06-17
Description
The Elementor Forms Google Sheet Connector WordPress plugin before 1.0.7, gsheetconnector-for-elementor-forms-pro WordPress plugin through 1.0.7 does not escape some parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- GSheetConnector Elementor Forms Google Sheet Connector: before 1.0.7; through 1.0.7 — fixed in 1.0.7
How to fix
Upgrade to a fixed version: GSheetConnector Elementor Forms Google Sheet Connector 1.0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/50d81eec-f324-4445-b10f-96e94153917e
- https://wpscan.com/vulnerability/50d81eec-f324-4445-b10f-96e94153917e
Get alerted when CVE-2023-2324 or the next vulnerability affects your stack