What’s Vulnerable › Vulnerabilities
CVE-2023-23315
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-01 · updated 2026-06-17
- Weakness: CWE-89
Description
The PrestaShop e-commerce platform module stripejs contains a Blind SQL injection vulnerability up to version 4.5.5. The method `stripejsValidationModuleFrontController::initContent()` has sensitive SQL calls that can be executed with a trivial http call and exploited to forge a SQL injection.
Affected products
- Stripe Payment Pro: before 4.5.5 — fixed in 4.5.5
How to fix
Upgrade to a fixed version: Stripe Payment Pro 4.5.5. Check the vendor advisory for mitigations.
References
- https://friends-of-presta.github.io/security-advisories/modules/2023/03/01/stripejs.html
- https://friends-of-presta.github.io/security-advisories/modules/2023/03/01/stripejs.html
Get alerted when CVE-2023-23315 or the next vulnerability affects your stack