What’s Vulnerable › Vulnerabilities
CVE-2023-23354: QuLog Center
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow remote attackers who have gained user access to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following versions: QuLog Center 1.5.0.738 ( 2023/03/06 ) and later QuLog Center 1.4.1.691 ( 2023/03/01 ) and later QuLog Center 1.3.1.645 ( 2023/02/22 ) and later
Affected products
- QNAP Systems Inc. QuLog Center: before 1.5.0.738; before 1.3.1.645; before 1.4.1.691 — fixed in 1.3.1.645, 1.4.1.691, 1.5.0.738
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QuLog Center 1.3.1.645, 1.4.1.691, 1.5.0.738. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-23354 or the next vulnerability affects your stack